Array error: Index was outside the bounds of the array

If the error “Index was outside the bounds of the array” appears, you have two opportunities to solve this problem.

After you updated your Act! database to version 16 or 17 and opened it, you should get the following error after a few seconds:

array error message

The first one is the Service Pack 1 for the .NET framework 1.1. It should solve the problem.
You can download .NET framework 1.1 Service Pack 1 from this link:

If you’re getting the error after an Act! Update to version 17 or 18 this way will help you out:

  1. Make sure that you have a backup of the database(s).
  2. Every user of Act! should be logged out of the affected database(s).
  3. Log on to the machine hosting the Act! database that needs to be repaired.
  4. Save the file, which is attached to the bottom of this article, to the desktop.
  5. If you’re using Windows Vista or higher, right click the file and select “Run as administrator”. Otherwise just double click the file.
  6. When prompted, type the name of the affected database and press Enter.
  7. Wait for the steps to complete. When prompted, press any key to close the Window.
  8. Repeat steps 5 – 7 for any other affected databases.

You can download the file here: Remove_Pending_Smart_Tasks.BAT



Leave a Comment